Enable accessible mode
Enable accessible mode

or

Firmware upgrade from 1.2.2 (or earlier) to latest version

If an Index V4 embosser with firmware 1.2.2, or earlier version, needs upgrading, you must order a series of two SD cards. The first SD card contains support to the new SD card type and the second SD card containing the latest firmware version. Contact your nearest distributor for details.